Bonds linux

From UVOO Tech Wiki
Jump to navigation Jump to search

interface Port-channel13

description foo ports
switchport access vlan 3
switchport mode access
spanning-tree portfast

!

interface GigabitEthernet0/1

description foo
switchport access vlan 2
switchport mode access
channel-group 1 mode active

!

https://serverfault.com/questions/445839/what-are-differences-between-balance-rr-and-802-3ad

6

From this page regarding balance-rr:

This mode is the only mode that will permit a single TCP/IP connection to stripe traffic across multiple interfaces. It is therefore the only mode that will allow a single TCP/IP stream to utilize more than one interface's worth of throughput. This comes at a cost, however: the striping often results in peer systems receiving packets out of order, causing TCP/IP's congestion control system to kick in, often by retransmitting segments.

And regarding 802.3ad:

The 802.3ad standard also mandates that frames be delivered in order (within certain limits), so in general single connections will not see misordering of packets.

So 802.3ad provides better ordering of packets which avoids TCP retransmissions.

802.3ad also only transmits on one NIC for each connection though FWIW... – 
rogerdpack
 Jun 11, 2021 at 18:32
Add a comment
3

You are wrong. Both balance-rr and 802.3ad must have a supported switch (EtherChannel).

balance-rr: Frames are transmitted in a round-robin fashion without hashing, to truly load balance.
802.3ad: This mode is the official standard for link aggregation, and includes many configurable options for how to balance the traffic.

If you don't have EtherChannel support use Balance-ALB or Balance-TLB. Both techniques uses a MAC change when sending (TLB) or sending/receiving (ALB)